Получение Subclipse в Aptana для работы с новейшей версией Subversion

Версия Subclipse (1.2.4), доступная в настоящее время через автоматический диспетчер подключаемых модулей Aptana, не работает с новейшей версией Subversion.

Однако я вижу на веб-сайте Subclipse, что у них есть версия 1.4.2 для Eclipse. Поэтому я добавил в свой менеджер обновлений новый сайт удаленных обновлений . Когда я попытался установить его, он сказал мне, что мне нужен Mylyn 3.0.0 . Итак, после долгих поисков я нашел Mylyn 3.0.0 и добавил еще один новый удаленный сайт обновлений в свой менеджер обновлений. Затем, когда я попытался установить это, он сказал мне, что мне нужен org.eclipse.ui 3.3.0 или аналогичный.

Если посмотреть на детали конфигурации Aptana, похоже, что она построена на основе eclipse 3.2.2.

Кто-нибудь знает, есть ли способ обновить версию Eclipse Aptana, на которой построена версия, до 3.3.0? Или есть другой способ заставить Subclipse работать с самой новой версией Subversion?

Я знаю, что это не обязательно вопрос «программирования», но я надеюсь, что это нормально, поскольку он очень важен для опыта программирования.

Ответов (4)

Решение

Subclipse не требует Mylyn, но на сайте обновлений есть плагин, который объединяет Mylyn и Subclipse. Это предназначено для людей, использующих Mylyn. В вашем случае вам нужно просто отменить выбор Mylyn в диалоговом окне обновления.

Subclipse также требует Subversion 1.5 и соответствующей версии собственных библиотек JavaHL. Я написал начало FAQ, чтобы помочь людям понять JavaHL и способы его получения. См .: http://desktop-eclipse.open.collab.net/wiki/JavaHL

У меня были проблемы с JavaHL в Eclipse Ganymede, когда он работал нормально в Eclipse Europa. Я не уверен, чем отличается Aptana, но попробуйте либо обновить JavaHL, либо переключиться на реализацию SVNKit на чистом java в конфигурации Subclipse.

Я использовал URL обновления и я установил адаптер JavaHL, сам Subclipse проект и в SVNKit адаптер BETA.

После этого у меня все заработало, это для платформы Linux, надеюсь, это сработает для вас.

если вы не собираетесь использовать mylyn, просто снимите флажок с этой зависимости. Я не очень знаком с Aptana, но в eclipse вы можете расширить то, что установлено, и снять отметку со всего, что вам не нужно.