Затмение на win64

Кто-нибудь успешно использует последнюю версию Eclipse для 64-разрядной версии Ganymede в 64-разрядной версии Windows XP или Vista?

В настоящее время я запускаю обычный дистрибутив Eclipse 3.4 на 32-битном JDK и запускаю и компилирую свои приложения с 64-битным JDK. Наш предыдущий опыт показал, что 64-битный дистрибутив Eclipse нестабилен для нас, поэтому мне любопытно, успешно ли кто-нибудь его использует.

Мы используем JDK 1.6.0_05.

Ответов (2)

Решение

Я использую Eclipse с 64-битной виртуальной машиной. Однако я должен использовать Java 1.5, потому что с Java 1.6, даже 1.6.0_10ea, Eclipse аварийно завершал работу при изменении файла .classpath. В Linux у меня были те же проблемы, и я мог заставить 64-битный Eclipse работать только с 64-битной Java 1.5.

Проблема, похоже, связана с своевременной компиляцией, поскольку с vmparam -Xint eclipse работает, но это не решение, потому что тогда это медленно.

Редактировать:

С 1.6.0_11 вроде работает.

1.6_10 final может работать так же хорошо, как упомянуто в комментарии, но я не тестировал это.

Я успешно использовал его в Vista x64 для легкой работы с Java. Ничего особенного и никаких дополнительных плагинов, но базовое кодирование Java работает без проблем. Я использую сборку 3.4M7, но похоже, что стабильная сборка 3.4 теперь поддерживает Vista x64.